API high latency

Incident Report for SnapCall

Resolved

Service looks stable and everyone is back online and calling.
Posted Feb 20, 2020 - 12:30 UTC

Monitoring

API Latency time have been restored to its usual level, and most users are back in. Service looks to be stable.
We are following up with AWS for a postmortem of the underlying issue, and are monitoring.
Posted Feb 20, 2020 - 11:50 UTC

Identified

We are investigating the issue. We are noticing anomalously high latency network with our database cluster. Traffic is routed to backup cluster.
Posted Feb 20, 2020 - 11:35 UTC

Investigating

We're experiencing an elevated level of API latency and are currently looking into the issue.
Posted Feb 20, 2020 - 11:20 UTC
This incident affected: API.